Bonjour,

Encore une petite astuce pour eclipse.

Si au gré de l’installation d’applications diverses et variées, vous avez été obligé d’installer plusieurs versions différentes du JRE (par version, je parle de jre6, jre7, mais aussi de 32 ou 64bits), vous aurez sans doute un message d’erreur de ce type :

 

Dans ce cas, impossible de lancer eclipse.

La plupart du temps c’est parce qu’eclipse cherche une JRE 32bits et qu’il trouve une 64, ou l’inverse.

 

Le plus simple pour éviter de casser le lancement des autres applicatifs, et de trifouiller dans les variables d’environnement, c’est d’indiquer à eclipse quelle JRE utiliser.

C’est également bien pratique si vous avez un eclipse sur un disque dur portable, et que vous n’êtes pas sûr de la version disponible sur le pc sur lequel vous comptez travailler.

 

Bref, récupérez la version du JRE compatible avec votre version d’eclipse par ici : https://www.java.com/en/download/manual.jsp, puis installez là.

Une fois installée, copiez le dossier “jreX” (où X indique la version, 6 dans l’exemple) à la racine de votre dossier eclipse :

ScreenShot054

 

Ensuite, éditez le fichier “eclipse.ini” à la racine de votre dossier eclipse toujours :

ScreenShot053

 

AVANT (c’est important, d’où les majuscules :)) la déclaration “-vmargs”, ajoutez ceci (sur 2 lignes) :

 

(Remplacez bien sûr la version si ce n’est pas une 6 !)

 

Si tout se passe bien, au lancement d’eclipse, plus d’erreur. Vous connectez votre disque sur un autre pc : plus d’erreur, le chemin est relatif !

 

Bon codage ;)